HTML files not cached, despite rule

I’m trying to cache .html file on my site. My site is “thai-notes.com”, and all the .html files are static. I have a rule:

thai-notes.com/.html
Browser Cache TTL: 8 days, Cache Level: Cache Everything, Edge Cache TTL: 7 days

However, when I look at the headers of any .html page I see:

cf-cache-status: DYNAMIC

I’m on the free plan, if that makes a difference.

What am I doing wrong?

Thanks.

It appears that the bulletin board has mangled my rule. The first line should read:

*thai-notes.com/*.html

Can you provide a URL for us to test?

You appear to currently have a security issue.

https://thai-notes.com/index.html

Attached is a screenshot of what I get for that link.

Can you post a list of page rules that you currently have?

Screenshot of page rules attached.

Your Cache Level is Standard, different than what you mentioned in the beginning:

Just make sure the Cache Level setting is correct and you are good to go.

Except for one thing of course :slight_smile:

Yeah, and I believe the OP will choose to ignore it like most people did :slightly_smiling_face:

1 Like

Thank you very much. That’s fixed things. Sorry to have wasted your time, I’m very new to this and am fumbling my way around.

You’re right. To be honest, I didn’t want to move to https at all. I consider it an unnecessary overhead. My site includes gathers no confidential information and asks for no payment. It also doesn’t show ads, and is completely self-funded. I really don’t want to have to fork out for an expensive certificate. I also have the issue that there are URLs embedded in my code using http which would all have to be changed and the source recompiled, which would be a nightmare. I’m happy with Cloudflare handling these as https to the browser, whilst passing them on to the server as http. Is it really that big a security risk?

Anyway, thanks to you and sandro for the feedback.

That’s perfectly fine, switch it to “Off” and you’ll nowhere have HTTPS.

Since when are they expensive?

And that’s exactly the problem.

The article covers this in its entirety. Not only is it as risk you are lying to all your visitors.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.