How to setup WSS?

Hey all, for my new application I want to use WebSockets, but I’m having trouble setting it up.

When I run the websocket server (which is currently just a echo server to test), and let it run on port 8880 (which is forwarded), I can connect to it with ws://domain:8880.

However, as the frontend will use https, i’ll have to use wss instead of ws. When I run the server on port 8443 (which is forwarded as well), I can’t connect to it with either ws or wss. ws://domain:8443 gives me a 400 bad request error (because wrong protocol i assume), and wss://domain:8443 gives me error 525. I use the flexible ssl/tls encryption mode, so I don’t think Community Tip - Fixing Error 525: SSL handshake failed could be applied. TLS 1.3 is disabled btw.

What can I do to fix this issue?

Kind regards,
sys-256 (Bram)

In that case you have a security issue which you need to fix first.

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.