How to setup Tunnel and work with HTTP proxy

I have a HTTP proxy setup in my local network using raspberry pi. I want to use the tunnel with a public domain, and this domain will point to my local network’s proxy server. Basically I have the similar question as this (

Using this can get the correct response:
root@raspberry:/# curl -x http://localhost:8080 -v

But below command no response:
curl -x -v

What I tried is setting up the tunnel using docker and on the Cloudflare tunnel dashboard, set the public domain pointing to my localhost network’s http proxy server. If I just go to, it will shows a Cloudflare’s 502 page? Shouldn’t it show the same blank page as I just go to my http proxy http://localhost:8080 page on the browser?

If I run below command on my local and it works showing 302:

curl -x -v

HTTP/1.1 302 Found

If I use the public domain that I setup on Cloudflare tunnel, it won’t work and show HTTP/1.1 409 Conflict

curl -x -v
* Mark bundle as not supporting multiuse
< HTTP/1.1 409 Conflict
< Date: Fri, 12 May 2023 01:08:24 GMT
< Content-Type: text/plain; charset=UTF-8
< Content-Length: 16
< Connection: close
< X-Frame-Options: SAMEORIGIN
< Referrer-Policy: same-origin
< Cache-Control: private, max-age=0, no-store, no-cache, must-revalidate, post-check=0, pre-check=0
< Expires: Thu, 01 Jan 1970 00:00:01 GMT
< Server: cloudflare
< CF-RAY: randome-string
* Closing connection 0
error code: 1001

I also try the policy rule set to bypass but same result not working.