How to set up EMAIL (MX) and keep CNAME PROXIED (please help)

Hello,

Sorry for my english (i’m french)

I’ve set up my email (MX) on OVH. [email protected]

But now when i want to record a CNAME -> @ -> www.tonsuperbusiness .com on cloudflare : i can’t have a CNAME Proxied , and i have a message about CNAME flatering.

The probleme now is : when i go to tonsuperbusiness.com without www -> it’s saying my site it’s not safe, and people can’t acces.

Can you help me ? Is there any solution ?

Thanks !

Hi @david79,

You can’t proxy the CNAME because of The orange to orange problem, basically because Clickfunnels also use Cloudflare.

Given that your www works, I would suggest you remove that CNAME and follow Redirect example.com to www.example.com

OK Thanks a lot domjh

And where can i do the follow Redirect exemple.com to www.example.com ?

Can you explain me how can i do that (sorry i’m a newbee)

No problem!

In step 1, you add this in the same place you added the CNAME earlier, but lust make it an A record with the content in the tutorial.

Then, in step 2, if you are not familiar with page rules, perhaps stary with this video which introduces the settings and then follow the specific tutorial for what you need to add.

If you need any more help, please just let us know!

Thanks a lot, you’re a good guy ! I’ve do all the steps. but still not working.

Please check the screenshots. my domain .com (without www) it’s steel not securised

Capture d’écran 2020-01-04 à 13.18.04|690x206

No problem, thanks :slight_smile:

It works for me and I am now redirected from the root domain to www, I suspect it may be a caching issue on your end which will clear in time, if in a couple of hours it still doesn’t work, please post back and we can have another look.

For reference:

HTTP/1.1 301 Moved Permanently
Date: Sat, 04 Jan 2020 12:27:21 GMT
Connection: keep-alive
Cache-Control: max-age=3600
Expires: Sat, 04 Jan 2020 13:27:21 GMT
Location: https://www.tonsuperbusiness.com/
Server: cloudflare
CF-RAY: 54fd34c03b23dfad-FRA

OK thanks my friend ! You’re great !

I’ve also find another solution, that i’ve tried with another site. I will tell you so it could help other people :

I added in clickfunnels 2 website : the one with www. and the same but without www
so : www. domaine .com and domaine.com

And no need the change the CNAME.

See you and thanks again !

I’m glad you managed to find a solution and thanks for letting us know!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.