How to set up email forwarding

The domains are now active, according to e.mails I have received. So that is a success!

Here we go again, though, with the next step… I want to forward e.mails, I have the page which tells you that it can be done, but no instructions on either how to do it or where to get the instructions.

My hair, already thin, is being torn out rapidly!

Here are some links to get you started:

Enable Cloudflare Email Routing
Cloudflare Email Routing Documentation

Those links are from

I did not check each of your sites, but to enable email routing/forwarding you’ll need to ensure you have the correct DNS records in place. That is this section of the email routing documentation link above, Email DNS records · Cloudflare Email Routing docs

Let us know if you run into issues. Glad everything worked OK getting the websites active.

1 Like

Either the link to the documentation or the get started button? Just a heads up… the feature has severe limitations, using a 3rd party mail hosting provider and spending a few $s would probably be a much better choice.

2 Likes

How will I know if the ‘correct DNS records’ are in place?

Once again, I’m seeing a lot of descriptions and very little in the way of instructions.

Start by going through the process here

As a next step, go here :point_up: :point_right: https://dash.cloudflare.com/?to=/:account/:zone/email/routing/overview

1 Like

Thank you, I got one done. Just one…

I tried to do another and it went a different way, I got no option to put an e.mail address onto the second domain at all. None.

What gives? Why is this so terribly difficult?

Mind you, this is not the only problem I’m having. I have now tested incoming e.mails to the address I re-routed. Find.

But I tried to send an e.mail from my regular e.mails using that address as a return address. This message is one with which I have become familiar in the last seven or eight months:

The following message to a gmail address was undeliverable.
The reason for the problem:
5.3.0 - Other mail system problem 550-‘5.7.26 This mail is unauthenticated, which poses a security risk to the\n5.7.26 sender and Gmail users, and has been blocked. The sender must\n5.7.26 authenticate with at least one of SPF or DKIM. For this message,\n5.7.26 DKIM checks did not pass and SPF check for [my e.mail] did not pass\n5.7.26 with ip: [203.59.1.232]. The sender should visit\n5.7.26 *** link unable to be shown - gsmtp’

So the question is, having set up all those records on this site for the one I was allowed to attempt such on (that’s right, I still can’t set up any more…) they are failing to do their job.

Folks, my back is to the wall here…

I have to get these addresses all set up asap so life can go on smoothly. They are no longer being re-routed by GoDaddy and I don’t want people everywhere getting bounce messages.

Please tell me how to set up the addresses for the other domains I have transferred in.

And it just gets worse!

I have an e.mail telling me that I need to put the authorisation code in for the transfer of the ramojan domain. But I can’t for the life of me get anywhere that it’s possible to put it in!

I have the code, I thought I put it in two days ago.

Perhaps your best bet is to hire a consultant or contractor to perform this work on your behalf. The internet is inherently technical. Cloudflare registrar is an ‘at-cost’ barebones service. Email forwarding is ‘free’. With both you get exactly what you pay for.

3 Likes

That won’t be happening…

Why should it all go smoothly for the first and be impossible thereafter?

And I now realise that I can post the message I got and couldn’t post in text above…

This is the everyday result of trying to send an e.mail to any Gmail account when I use my own e.mail addresses as the return address.

The error message elaborately states the problem. You need to ensure that any mail you send using your email address meets those authentication requirements. That is a question you will need to answer with the assistance of your external email provider. They will have the information needed for your SPF and DKIM records.

2 Likes

For months they were telling me I had to sort that with GoDaddy…

And for months, each time I got in touch with GoDaddy they told me they had fixed it, “It will take effect in a couple of days…”

And it never has.

If Go Daddy is your email provider then you need to enter the information they provide in your DNS records. If Go Daddy is not your email provider then Go Daddy is not who you should be speaking with @epic.network indicated this information comes from your email provider.

3 Likes

GoDaddy is not my e.mail provider, iinet is. But that’s in the throes of changing to another one, the Messaging Service or something. Something else which is being forced on me.

Anyway, as already explained, I talked at length to iinet about it, they sheeted the blame off to GoDaddy. I know not, just that GoDaddy told me about five times that they were fixing it and it’s still not fixed.

Go Daddy is no longer your DNS provider. You have moved to Cloudflare which is a self service provider so you can create whatever entries you need. You will need to communicate with your email provider to confirm what entries need to exist and create or modify as needed with regards to your SPF and DKIM records.

2 Likes

Now I’m getting many e.mails from Cloudflare, they are ‘Form of authorisation notices’, they don’t appear to require any action by me and they do appear to be being repeated day after day. I have transferred five domains, I have 19 or so of these notices.

And I still don’t know how I’m going to get the rest of the e.mail routing done. It’s a mystery to me, I did the first one and the options I took with it simply don’t come up when I click on the others. I don’t know if anyone recognises what I’m saying here, but the option to set up the other e.mail routing doesn’t appear when I go to those domains in my dashboard. And just so there’s no mistake, I successfully did it with just one of them.

I don’t know if anyone is taking any notice, but I certainly am.

Every step of the way I get more and more e.mails from Cloudflare, but each of those steps is accompanied by a further restriction on my activity.

I now cannot even log in to Cloudflare, it tells me that my e.mail and password don’t match. I click on the ‘forgot my e.mail’ button and I’m told that I’ll get a message, but that never comes.

What can I do?

Okay, I solved that. The password saved by Firefox was before I was obliged to modify it and I never got the chance to update it.

But I still never got any e.mails, two days passed, none. Yet I’ve had over twenty of those ‘authorised’ e.mails.