How to set my domain having HTTPS by default?

Hi,

I am using DNS in cloudflare. Currently, my domain can be accessible from both HTTP and HTTPS. However, I prefer to have HTTPS by default when user hits “xxx.com”. Currently, it “http” by default. I have “Always Use HTTPS” turned on in Edge Certificates section. Anyone know what I am missing here?
I have also added page rules:
http://xxx.com/*” -> Automatic HTTPS Rewrites
Still not working. Please help.

Thanks.

“Always Use HTTPS” should do it. What’s the actual domain?

p.s. There’s already an Automatic HTTPS Rewrites option below the Always option, so you won’t need a Page Rule as well.

Yes, I have noticed that too. Both options are turned on. Still now working after waiting for more than one day.

the domain is hide-again.com, FYI. Note that, both HTTP and HTTPS work, but HTTP is the default which is the issue.

It’s definitely not redirecting to HTTPS. And those settings should take effect immediately. Are the two name servers at the bottom of your DNS screen peaches and lennon?

Oh, and your setting looks like this, right?

Yes, check out my screenshots below.

image

I’m out of ideas. That should be working. Maybe Support can figure it out.

To contact Cloudflare Customer Support, login & go to https://dash.cloudflare.com/?account=support and select get more help. If you receive an automatic response that does not help you, please reply and indicate you need more help.

Thanks all the same.

This topic was automatically closed after 30 days. New replies are no longer allowed.