Hi Admin,

I’m using osclass cms for one of my website. and tried to add Free SSL on it. but unfortunately i can’t. getting so many errors. i just click on on “Always use HTTPS” under crypto. the website was running properly. but i’m unable to log in my admin section. getting errors for the same. So i need to remove HTTPS from it.

I did it same just off the “Always use HTTPS” and the website is running fine. but on browser chrome when i type https the website is opening not properly. that means the website is mixed content.

kindly help me how to fix for the same. I just need to remove HTTPS and need to use simple website.


Why remove HTTPS?

You should redirect to HTTPS only on one side. Ideally Cloudflare should do the redirect, not the webserver and then, if you have a certificate on you server, switch to Full the SSL setting. If the certificate on the server is valid use Full (Strict).

You would be better off fixing the HTTPS errors.

Try: Cloudflare SSL/TLS settings and enable Automatic HTTPS Rewrites.

And also add this line to .htaccess:
Header always set Content-Security-Policy: upgrade-insecure-requests

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.