How to register Warp Client for linux via terminal?

Hello. I’m having an issue in regards to registering into our teams account for Warp. I saw this solution below from a different thread

Couple of easy steps

  1. Go to https://.cloudflareaccess.com/warp and authenticate.
  2. On the ‘Success’ page in the browser, right click and ‘Inspect’ the blue ‘Open Cloudflare WARP’ button. Copy the long token that’s shown linked to the button, and then type the following into a command prompt on the remote server: warp-cli teams-enroll-token https://<team>.cloudflareaccess.com/auth?token=<token you copied>.

Can probably replace teams-enroll-token with registration initialize-token-callback

However I am encountering Error: “Failed to parse TokenCallback URL”

I just copy pasted this enclosed with {}

The solution that I indicated was here.

@Cyb3r-Jak3 Have you ever encountered this error?

My only point would be to look at the token and make sure there aren’t any weird spaces or quotes included accidentally.

Thanks for replying. But I double checked it and I just ran the warp-cli teams-enroll-token https://<team>.cloudflareaccess.com/auth?token={the token shown on the browser} but to no avail.

Sanity check, that token you show in the screenshot has a page of auth expired. Have you tried with one that doesn’t have that web page?

I got another error
warp-cli registration initialize-token-callback “https://myteam.cloudflareaccess.com/auth?token=XXXXX

error: unexpected argument "[https://....](https://myteam.cloudflareaccess.com/auth?token=XXXXX)"

How could be fixed it?
Thank you in advance

Try just doing the token and not the full URL.