How to reduce fontawesome-webfont load time using cloudflare

fontawesome load time in my wordpress site is very slow, how to reduce it using cloudflare pro?

ex : https://domain.com/wp-content/themes/publisher/includes/libs/better-framework/assets/fonts/fontawesome-webfont.woff2?v=4.7.0

That file should be cached by default. If you posted an actual URL, we could test it.

1 Like

Actually there is the parameter “?v=4.7.0” which makes this request dynamic and not beeing served from CloudFlares edge servers, but instead beeing proxied to your origin Server which is way slower.

Please have a read here:

To change the dynamic links in your HTML to static ones which makes it possible for CloudFlare to cache your files.

Alternatively you could search for a Plugin which removes all version-strings from your files/links in your HTML/DOM

#EDIT: seems like this is able to do so https://wordpress.org/plugins/wp-version-remover/

Hmmm…I thought even with a Query String, it would cache static resources with query strings unless the setting was changed.

1 Like

True that!
So we should know his settings, as they could possibly be the cause of not beeing cached at CloudFlare. But you are right. If he set them to “ignore query string” then its not the query string.

1 Like

Or even Standard will work. Especially since that query string is unlikely to change often.

1 Like

Yes we really should get an link to test. Otherwise its hard to say why it is slow.

1 Like

That file is cached by Cloudflare and loads quickly.

1 Like

but why i see it slow in https://developers.google.com/speed/pagespeed/insights/?

Well your site and its files are getting served fast, but they are not optimized!
Thats the problem. Not the fonts beeing served slow.

1 Like

What are you suggest to me to optimize site, I am using LiteSpeed Cache plugin.

I would suggest:

  1. read GPSI and research how to solve these things its complaining about
  2. hire someone who can optimize your site
1 Like

oke thank you

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.