How to prevent dc-*.example.com adding in SRV record "target" field?


#1

I’m using CloudFlare only as DNS resolver and I trying to add xmpp SRV records like this:

_xmpp-server._tcp.example.com. 86400 IN SRV 5 0 5269 example.com.

In “Edit record: SRV” form “Target” is example.com

but instead example.com. i have got dc-d88d714ce3c1.example.com. in record:

 host -t SRV _xmpp-server._tcp.example.com
_xmpp-server._tcp.example.com has SRV record 5 0 5269 dc-d88d714ce3c1.example.com.

Why solid record not allowed? dns.he.net can create it like a charm.


#2

This is a shadow record.

DC means direct-connect and was implemented to avoid conflicts with MX records. There may be some conflict with your settings as well.


#3

This topic was automatically closed after 14 days. New replies are no longer allowed.