How to not redirect Twitterbot when using cloudflare SSL?

Please, I’ve been trying to do this for days, nothing has worked. Twitter cards won’t allow https from a shared SSL including cloudflare. The workaround mentioned is to create an .htaccess file and add code to not redirect twitterbot. The problem is this is breaking my pages saying there are too many redirects. I tried putting the twitter card image in a directory called /social/ and putting this page rule in cloudflare: my.com/social/ - Disable Security as the first rule, with no .htaccess codes and this simply is ignored by twitterbot even though if i manually put the path to the image in that directory it’s correctly not redirecting to https. PLEASE, I can’t be the first person to come across this compatibility issue with cloudflare SSL and twitterbot. There’s no info anywhere on what to do. If anyone can advise you’ll be the champion of all champions!

2 posts were merged into an existing topic: Need twitterbot to NOT redirect