How To Make URL Appear Properly?

I’m pretty new to all this yet and still learning. :innocent:

I am pretty sure I have an SSL installed on my server (otherwise, wouldn’t the https://breekatt.io not work?)

Here’s a few pictures of my SSL settings, I’m hoping they might help. I’m not sure what you mean or how to check on my ‘encryption mode’ - can I send a screenshot of that as well?



THANKS!

No, because that’s only the proxy certificate

For starters, you should change that to “Full strict” an check if you get a 526 error.

Not sure what proxy certificate means either but I can look into that to learn more.

I have set my site to ‘Full Strict’ but there seems to be no change, and no error as far as I can tell. breekatt.io still shows as ‘not secure’ however. Not sure if this made any difference, unless it takes time to propagate?

It’s IPFS, so it’s uncharted territory for me. I believe hers is hosted by Pinata, though I don’t think that matters since it’s IPFS.

https://developers.cloudflare.com/distributed-web/ipfs-gateway/connecting-website

1 Like

1457022245-3-Fear-and-Loathing-in-Las-Vegas-quotes

Not that I’d even know how to spell that, but isn’t the issue that the naked domain simply isn’t proxied, hence the settings won’t apply either? @breekatt, can you switch the naked domain from :grey: to :orange:? That should do the trick.

Yes! I pin my HTML files to Pinata and my IPFS desktop node. Also, my domain registrar is bought on Dynadot, though I have my nameservers set to Cloudflare. (apologies for not mentioning)

How do I switch the naked domain from :grey: to :orange:? I really have no idea what that means. But I’m willing to try anything that I can. :thinking: :grinning_face_with_smiling_eyes:

Please check out support.cloudflare.com as well as #tutorials. These questions are all covered there.

Ook no problem, but :grey: to :orange: are icons so kinda confusing to know what exactly I’m looking for. What even are those loll, I will do my best. o.o

For anyone else (reading this) who may need help with the same issue as me - I assume/hope this is the tutorial we need?: Step 3: Enabling the 'Orange Cloud'

If that is the tutorial I needed to follow in order to change :grey: to :orange: then I’m really at a loss because the cloud that I had under ‘proxy status’ was already set to orange. Starting to think it’s hopeless to get my URL to appear as secure haha? Maybe I could try to contact Cloudflare directly perhaps, not sure if they would reply. :shushing_face:

Hi @breekatt,

From this reply, I believe it’s not possible for you to do this yourself on an IPFS site. Cloudflare would have to do this manually.

Tagging @thibault1

Thanks for the reply and I really appreciate everyone trying to help me solve this!!

To be clear, there is nothing else to be done on my side of things? Not sure what 'Cloudflare would have to do this manually" means, exactly…? Perhaps if I contact them to ask about this, they can help me manually fix the issue? Haha! I’m trying to understand, forgive me.

Suppose it’s not a super huge issue as I can still use the other address configurations, I only wish it would work on the main domain (breekatt.io) so visitors know their connection to my site is secure.

No, you can’t do anything else. I believe the reason you cannot proxy the record for the root domain is because of The orange to orange problem, which essentially means that there are two Cloudflare configurations layered. This won’t work and it means that settings such as “Always Use HTTPS” and Page Rules will not work when you set them on your account.

Because you are using a Cloudflare service behind Cloudflare, their configuration takes priority over yours, so they would need to enable the HTTPS redirect.

I’ll escalate this thread with your domain breekatt.io and see what they can do and whether they can get it enabled for you.

Very interesting. I hope ‘configuring two cloudflare layers’ wasn’t something I accidentally did. I would definitely appreciate the escalation of this issue and hopefully it can still get sorted out.

Thank you!

Not at all. It’s just what happens when you have your own Cloudflare setup and also use a product that uses Cloudflare. In the case, IPFS uses Cloudflare and so do you.

It’s in the queue, hopefully someone will get back to you here soon.

No problem, hope it gets sorted for you!

1 Like

Hi @breekatt,

I have enabled “Always use HTTPS” for breekatt.io.

2 Likes

Thank you so much!

I’m curious if it matters that I continue to edit and reupload my website at all, though? I make edits, deleting the old pin and repinning the new one and adding the new hash to my cloudflare DNS settings. I’m hoping this won’t affect that in any way? And that BreeKatt.io will continue to point to HTTPS regardless?

I know it takes time for the site to propagate and for changes to be made. For example, when looking at my site right now (after a recent edit/update) the URL shows http://breekatt.io.ipns.localhost:8080/

Also, the site isn’t loading properly but I think that might be a Nicepage problem (the software I use to build the site) so I’ve reached out to them because of that.

Ultimately, my question is - once everything has settled and propagated - if my site will point to HTTPS on breekatt.io regardless of any changes I make on my end?

I will have to give it a few days I think, to wait and see what happens with the URL and perhaps let you know. This is all such a learning curve and a process haha. Interesting to learn though.

Thank you again. :smiley:

Update on the reason why my site wasn’t loading properly for me was because I had to hard reload my cache HAHA. - Still have the same question about the HTTPS though. :slight_smile:

HTTPS configuration should stay, regardless of what configuration you do on your side. This shall be true as long as the traffic of your domain is managed by Cloudflare IPFS gateway.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.