How to make my subdomain from cPanel to be added automatically as A Record in my cloudflare account

Hello there, so as my Topic said I am using shared host for my website/project. So what I want is somehow my subdomains which I am creating to be adding automatically to cloudflare.
I have enable the option in cPanel for cloudflare and when I create subdomain it does show there in cloudflare from cPanel, but when I login to my account here at cloudflare it is not here… I have no idea what to do, host support is saying that I can remove the website from my cloudflare account and leave only the one from cPanel but they said they are not sure about that … I am sorry for my english I have try to explain it much as I can… anyway if somebody has idea what I can do please let me know…

There are three options:

  1. Your cPanel host already does this automatically (IF they are a Cloudflare Partner and control your DNS).
  2. You have to add it manually after you add it to cPanel.
  3. You write a very complicated script that does this. I don’t think anybody would choose this option.

Hi sir thanks for your reply.
So you are telling me if my host has Partner with Cloudflare and cPanel, I can feel free to remove my website from my Cloudflare account and let everything be doing from cPanel ?

Correct. A partner setup means they handle your DNS. Probably a bunch of other Cloudflare options as well. You would have to see if they have the option to “Enable Cloudflare” for your domain.

Well okey now I have remove my domain from cloudflare let see what will happen, hope the dns would be okey.

Okey now what happen is all of my subdomeins are not working. it say This site can’t be reached and all of subdomins from my cpanel cloudflare are there .

If your host is a Cloudflare Partner, they should be able to guide you through this.

Okey I just maybe found my problem but not sure does my Nameserver should going to cloudflare ? or they should be normal as default ? where my cpanel host is?

If they are a partner, then Name Servers should be set to your host’s name servers.