How to install ssl from letsencrypt?


#1

To get a certificate from letsencrypt, I need to confirm that this is my domain by downloading the appropriate file to the root of the site and go to this address. But connecting CloudFlare I can not do it. If I click to bypass the cloud on the DNS tab in CloudFlare, then my site will be redirected many times.
If I click not to bypass then just a message goes that there is a problem with the SSL certificate?


#2

Can I completely remove the site by clicking on the cross in the DNS tab on CloudFlare? And then add again when I get the certificate? But it will have to wait a day or two?


#3

In this case, you should only need to bypass just long enough for Let’s Encrypt to install the certificate, then re-enable Cloudflare. It should only take a few minutes.


#4

I first need to click on the dagger on the DNS tab to delete a domain and then get a certificate? So what?


#5

No need to delete…just set that DNS entry to :grey: so Let’s Encrypt can reach your site directly. LE will typically ignore redirects as it verifies your domain.


#6

Это как Не понимаю ?


#7

This is how I do not understand?


#8

Click the :orange: for that DNS entry so it’s set to :grey:.


#9

Then there is an endless re-addressing.


#10

Did you try setting it to :grey: so Let’s Encrypt could verify the file?


#11

Yes, it turned out to install! F now in CloudFlare. Do I have to enter something or just install a certificate on my hosting and that’s it?


#12

Yes, it turned out to install! F now in CloudFlare. Do I have to enter something or just install a certificate on my hosting and that’s it? See for yourself https://forum.helpsetup.ru/


#13

I installed the certificate on my hosting and this is what happens: https://forum.helpsetup.ru/


#14

You forgive me. I still have to translate accounts. I apologize if what has hurt you or what I said wrong)))


#15

No problem.

That SQL error may happen if it is configured to connect to your hostname that is set to :orange:.

Try configuring your forum to use ‘localhost’ or the IP address of your server.


#16

It seemed to work, but when I made the cloud gray, my forum did a lot of re-addressing. And when I made the cloud orange, he reported an SSL error. So it turns out I can turn off the cloud and put the certificate on my website as usual on my hosting and then turn on the cloud again and everything will work? So ?


#17

Lord, give CloudFlare and good people who work in this company, all that they need, all that they can only wish for. I undertake to provide as much advertising as possible in my projects, discussions, and others, wherever you can indicate that there is CloudFlare and there are only good people there. I will certainly tell you about CloudFlare on my SEO website.
Thank you very much!


closed #18

This topic was automatically closed after 30 days. New replies are no longer allowed.