How to Get CloudFlare to just pass thru certain URLs


#1

Hi,

I’m trying to set up using CloudFlare with my server and having a problem.

I’ve got a couple of specific URLs that are used by an external application to communicate with the server and these applications are written to use http.

I’ve now got my server working with flexible SSL (since there is no cert on the server), Always use HTTPS on, and Automatic HTTPS rewrites on, so that all http traffic gets changed to HTTPS to get that magic little green lock that Google loves so much.

But this is causing the application to cough up a hairball when the http URL it is using is getting converted to HTTPS by CloudFlare. I need to turn off the switching to HTTPS for these URLs and have CloudFlare just pass them on thru to the server like CloudFlare isn’t there.

I thought creating some Page Rules for this would work, but I can’t seem to get any Page Rule to do this. I’ve tried to have it turn Automatic HTTPS rewrites off for the URLs, but that didn’t work. I tried having it turn SSL off, but that didn’t work either.

What setting do you have to change in order to get the HTTPS turned off for a page rule?


#2

I think you’ll have to disable Always Use HTTPS on the Crypto page. Then you should be able to add some Page Rules. One for each URL you want HTTP. Just add a setting for SSL: Off.

Then one final rule to match example.com/* and a setting for Always Use HTTPS. That should match everything skipped by the first two rules.