How to fix this error NET::ERR_CERT_DATE_INVALID

How do I fix this error: NET::ERR_CERT_DATE_INVALID

Here is the site:


May I ask if you get this message while using Cloudflare proxy :orange: or when you temporary “Pause Cloudflare” for your domain name? :thinking:

I get SEC_ERROR_EXPIRED_CERTIFICATE when I try to access your website.

I can access it only via HTTP. And I can see it’s currently unproxied.

As in current state unproxied and :grey: (DNS-only) or if you enabled the “Pause Cloudflare for this site” option at the Overview tab of Cloudflare dashboard for your domain, may I ask have you tried contacting your web hosting provider in terms of renewing your SSL certificate?

Otherwise, you might be able to renew it if you are using cPanel AutoSSL / Let’s Encrypt / ACME / Certbot.

Kindly, I’d suggest below steps:

  1. Use the “Pause Cloudflare on Site” option from the Overview tab for your domain at .
  2. The link is in the lower right corner of that page.
  3. Give it five minutes to take effect, then make sure site is working as expected with HTTPS without any error
  4. In case if you experience an SSL error like now, proceed to step 5)
  5. Check with your hosting provider / cPanel AutoSSL / Let’s Encrypt / ACME / Certbot and renew it
  6. Only then, when your website responds over HTTPS, you should un-pause Cloudflare and double-check your SSL/TLS setting to make sure it’s Full (Strict).
1 Like

I don’t know. What I do know is when I go to the site, I get the error message. I haven’t touched anything on the Cloudflare dashboard. I’m not sure who the hosting provider is. How would I check?

I can see HTTP header:
x-powered-by: WP Engine

Kindly, contact them to re-check and renew your SSL → expired yesteday.

1 Like

Thank you. I thought it was WPEngine but the documentation I had said to NOT contact them with this error.

WPEngine just fixed it. Apparently, although I had installed the patches last night, and it worked, the old cert overrode the new…it’s all fine now.

I appreciate your help and patience.


This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.