How to enable HTTP/3

Hi I enabled HTTP 3 from dashboard and I am using QUIC with argo tunnel. But I see that my html and some other content is still loaded in http2 while some are loaded in h3-29 in GT Matrix

Everything but the main page HTML loads with HTTP3. Even the header for the main page shows it should be QUIC, so I don’t know why it isn’t. Though I’m using Firefox, so I don’t know why Chrome doesn’t use QUIC. It looks like Chrome doesn’t get the alt-svc header.

Ah, I had to enable QUIC in chrome://flags

FIREFOX:

BRAVE/CHROME:

1 Like

I guess GT Matrix is also showing HTTP 3 in header.
I got confused !!

I think that Cloudflare will send that header regardless. It looks like that very first hit may be HTTP/2, and then your browser knows to use QUIC from then on, so that’s why everything else on the page loaded with QUIC. When I checked your home page a second time, I got H3.

1 Like

That’s how HTTP/3 works - first time visit is over HTTP/1.1 or HTTP/2 to read the alt-svc header to see if the server supports HTTP/3. If it does, then subsequent requests are over HTTP/3.

4 Likes

When is http 3 enabled, like when I enable it through dashboard or when I use Argo tunnel with QUIC or when I use cloudflare APO with QUIC enabled in dashboard

There are two separate connections here.

The Client to Edge connection is enabled through the dashboard. The client detects HTTP/3 in the alt-sec header. Modern Apple devices can also detect HTTP/3 through DNS lookups.

Using QUIC with Argo Tunnel is a separate connection from Edge to Origin, and has no bearing on the Client connection.

2 Likes

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.