How to enable doh on chome 78?

i just realize dns not working on new chrome 78 windows. method i use command line-flag
–enable-features=“dns-over-https<DoHTrial” --force-fieldtrials=“DoHTrial/Group1” --force-fieldtrial-params="DoHTrial.Group1:server/https%3A%2F%2F1.1.1.1%2Fdns-query/method/POST

“Not working”?

You can enable, or disable it via Chrome flags directly without command line flags.
It only works, when you’re already using 1.1.1.1 for standard DNS requests. (Google says)

What does https://1.1.1.1/help show?

It only works, when you’re already using 1.1.1.1 for standard DNS requests.
i dont quite understand this part.
how do i set standard DNS request?

type chrome://flags/ in url bar, search dns, and enable it

can someone help me as well? it just suddenly not working anymore, it worked an hour ago but when i tried to open reddit it just doesn’t work anymore. i tried using both the command line and enabling it from chrome/flags but is still doesn’t work.

https://1.1.1.1/help#eyJpc0NmIjoiTm8iLCJpc0RvdCI6Ik5vIiwiaXNEb2giOiJObyIsInJlc29sdmVySXAtMS4xLjEuMSI6IlllcyIsInJlc29sdmVySXAtMS4wLjAuMSI6Ik5vIiwicmVzb2x2ZXJJcC0yNjA2OjQ3MDA6NDcwMDo6MTExMSI6Ik5vIiwicmVzb2x2ZXJJcC0yNjA2OjQ3MDA6NDcwMDo6MTAwMSI6Ik5vIiwiZGF0YWNlbnRlckxvY2F0aW9uIjoiU0lOIiwiaXNwTmFtZSI6IlBULiBGaXJzdCBNZWRpYSwgVGJrLiIsImlzcEFzbiI6IjIzNzAwIn0=

You’ll need to enable it via the flags now, the old command line option from my other blog post is no longer valid.

When this is enabled, Chrome will identify which DNS resolver your system has set up. You can see this on Windows by running nslookup and looking at the “Address” field.

Here’s the output of mine, this is my Google WiFi router’s IPv6 address:

image

If it’s IPv4, it will show an IPv4 address instead.

Chrome will only use CF DoH if that “Address” is one of CF’s IPs, which are these:

1.1.1.1
1.0.0.1
2606:4700:4700::1111 (also formatted as 2606:4700:4700:0000:0000:0000:0000:1111)
2606:4700:4700::1001 (also formatted as 2606:4700:4700:0000:0000:0000:0000:1001)

If it’s not one of these, you will need to follow these instructions to set up Windows to use CF’s DNS resolver IPs.

Without setting it up:

After setting it up (I also had to set up the IPv6 DNS):

2 Likes

now its working.
thank you!!