How to enable cloudflare gRPC to proxy nginx-ingress grpc api

hello guys, i meet some issue when im using cloudflare to proxy kubernetes nginx-ingress gRPC service.

when i disable the cloud proxy, i can connect to my gRPC service normally, but i always got handshake fail when enable cloudflare proxy. what should i do or how to debug it ?

under is my settings

  1. enable network gPRC
  2. enable DNS proxy option

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.