How to disable the Web Analytics from my domains

I enabled this beta feature of Web Analytics and discovered it doesn’t give me any value, except for injecting the beacon JS.
How can I disable it?

All you need to do is head to the Speed tab > Browser Insights and then click on Web Analytics. Click on the Clipboard to the right of your domain then you can delete it there. You can also click on Manage Site to perform the same thing via Web Analytics.

Once you delete it you will need to go through the entire setup again if you want to enable it again.

Step One:

Step Two:

Step Three:

1 Like

Thanks! I used the second option successfully

1 Like

Hello, sorry for the trouble, we are fixing this problem and releasing the fix soon.

image
Sorry for your inconvenience. You can now click on to expand “Advanced Options” and click the toggle to disable JS snippet injection. This toggle is useful if you want to pause the injection in case if anything happens.

Hi,

I’ve gone through the options described here to disable web analytics on my site, but unfortunately I’m still seeing beacon.js being injected into my HTML.

  1. I tried setting it to disable automatic setup, but it didn’t make a difference. Beac
  2. I tried deleting the site from Web Analytics, but beacon.js is still being injected.
  3. I disabled Rocket Loader (it was another place that was injecting beacon.js).

I purged the cache on the site after changing all of the above, but no difference.

With Web Analytics on the site disabled, Is there any further troubleshooting I can do to remove beacon.js?

Update on this… in order to remove the beacon.js from my pages.dev site, I had to:

  1. Delete the site from Web Analytics AND
  2. Redeploy the static site from source.

After the redeploy, the injection of beacon.js was removed from the bottom of the index.html file.

1 Like

The delete button somehow now always disabled?

1 Like

For us even after we deleted a site from Web Analytics AND redeployed the static site from the source, the beacon is still injected. This leads to serious problems with Angular hashes. It has been 5 days and Cloudflare support is unresponsive. Cloudflare support has sent a schematic guide on Web Analytics through e-mail and did not respond for days.

How would this be done in the new nav menu? I just want to get rid of cloudflareinsights and sentry on my site

same problem, no answer from CF…

1 Like

I also found that some of my websites had the https://static.cloudflareinsights.com/beacon.min.js script injected.

If you go to Dash > Websites > Analytics & Logs > Web Analytics

You will see a list of websites, some of which have a gray cloud, which means that the analytics are not controlled by the DNS service, but are still present. If you go to Manage Site, you will see that the Disable button is not active, and you cannot do anything from this menu. But you will probably see a note at the top: “Manage this site with Cloudflare Pages where it was created”. This means that the injection took place at the Pages level. Yes, this applies to sites that are hosted on Pages as the origin server.

So, to get rid of beacon.min.js, you need to go to the Pages settings.

Go to: Workers & Pages > Project name > Settings > scroll down to Web Analytics > disable it.

Redeploy the site, clear the cache, and beacon.min.js will disappear.