How to disable DNS proxying?

I am trying to obtain a managed certificate as explained here:
https://cloud.google.com/load-balancing/docs/ssl-certificates#create-managed-ssl-cert-resource

The problems appear right away, because one of the requirements is as follows:

The DNS records for your domain must reference the IP address of your load balancer’s target proxy

On Cloudflare, I set an A record to 35.XXX.YYY.ZZZ for my subdomain example.domain.com. However, when I query the subdomain I get a different set of IP addresses, because Cloudflare hides the original one:

example.domain.com has address 104.25.137.22
example.domain.com has address 104.25.136.22

This causes the certificate provisioning to fail, because it does not see the correct IP address. This persists even if I disabling the proxying through the orange cloud icon.

How can this be solved?

Switching to :grey: does disable the proxy. If it still points to the proxies it rather is a caching issue. Simply wait a couple of hours.

1 Like

Indeed, now it works. I was just impatient, my bad.