How to disable CNAME flattening for MailChimp Authentication


#1

Hi all,

I hope you can help. I am trying to authenticate a domain in mailchimp and I’m having some trouble with the CNAME record.

I’m aware that the cause of the problem is CNAME flattening. However, I read online that by upgrading to pro this facility can be turned off. However, since upgrading I can see in the knowledge base that this isn’t the case.

Is there anyway of authenticating the domain without resorting to changing the nameservers back to the registrar for verification purposes?

Many thanks,

Steve


#2

Make sure it is not proxied but its icon is :grey:.


#3

Hi Sandro,

Thanks for the quick response. It’s not proxied but there is no cloud at all. I’ll attach an image.

30%20PM%20(1)

All the best, Steve


#4

Whats the domain?


#5

olivergoldsmith.com


#6

You have a point here. That does return an A record instead of a CNAME, meaning flattened.

I presume your flatten setting under “DNS” is not “Flatten CNAME at root”, right?


#7

That’s right… currently it’s flatten all CNAMES


#8

You’d need to switch that to root, but keep in mind this will “unflatten” all your CNAMES. AFAIK there is currently no setting to apply it only to specific entries.


#9

I’ve changed it.

Is this normally a quick change or will I have to wait for it to update.

thanks again, Steve


#10

It’s authenticated!! Thank you you’ve been a great help.

All the best,

Steve


closed #11

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.