How to disable caching in cloudflare completely and permanently?

Good afternoon! There is a website How to bypass or disable caching of all site pages in Cloudflare, you need to disable caching not temporarily, but forever. I tried to use the Developer Mode setting, but after 3 hours caching is turned on again, I tried to reset the cache using the Purge Everything button, but this only temporarily resets the page cache. I tried to change the Cache Level in the Cache - Configuration, the cache still does not turn off.
Also tried disabling Cloudflare completely as indicated here Подскажите, как полностью отключить кэширование для сайта? with the help of an orange cloud in the DNS section, I waited for a while after that, but the site stopped opening at all and began to issue an error Timeout error. I also configured the Page Rule for the domain to bypass caching, reset the cache after these manipulations, but caching still works and is not disabled forever. What should I do to disable caching permanently? What settings do I need to fix?
Do I need to use the Cloudfare API and write a php script for this?
I will show my current settings in the screenshots below:

Cloudflare isn’t caching your site pages. Nor will it by default. The home page is showing DYNAMIC:

What are you seeing that’s cached?

1 Like

There is a red button in the header on the site, when you click on it, a popup form appears when you send the form, when you click on the send button, the captcha is not displayed because of the cache, because of this, a message is not sent from the site. How can this be circumvented or fixed so that the captcha is displayed or disable the captcha request when submitting the form to Cloudflare if there is such an opportunity?

How can I prescribe a cache bypass rule for the domain’s main page or for all its subpages in Page Rules?

Despite cf-cache-status: DYNAMIC, the captcha is still not always displayed when submitting the form. Can the spam filter enabled by Bot Fight Mode or the rules in Page Rules affect the captcha?

for the main page the pattern is:

for the sub pages the pattern is:
(this also matches the main page)

For further PageRule understanding please read the docs:

Which captcha exactly? For me, no captcha was there and the form worked without problems:

I get a recaptcha with a check that I am not a robot, but it does not always appear for some reason and without this captcha, the message does not come to my email. How to make the captcha displayed and the message always came to the email, or so that the captcha was not displayed but the message came to the mail, while spam from bots did not come? Will the cache bypass rules and Bot Fight Mide mode that you wrote help with this, or do you need to use something else?

Does this captcha come from Cloudflare?
And if the captcha does not appear, please the next time open the developer console and post a screenshot of the “console”.


This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.