How to disable automatic installs of .tool-versions and package.json

My project uses asdf’s .tool-versions but requires installing plugins in order to install the versions specified. This causes builds to fail immediately after checkout, before running my first build step – which is installing asdf plugins :slight_smile:

Elsewhere in the forums, I found references to adding a build environment variable SKIP_DEPENDENCY_INSTALL set to 1 or true, but that doesn’t seem to work on the v2 image right now. Is there another incantation to achieve this outcome?

|6:24:56.519|Cloning repository...|
|---|---|
|16:25:01.932|From https://github.com/<myrepo>|
|16:25:01.933| * branch            deadbeef -> FETCH_HEAD|
|16:25:01.933||
|16:25:02.810|HEAD is now at deadbee fix(frontend/step-notes): send previous cell textRaw if not changing|
|16:25:02.811||
|16:25:02.932||
|16:25:02.981|Success: Finished cloning repository files|
|16:25:03.988|Warning: Specified NODE_OPTION --max_old_space_size value is higher than allowed - setting to 7620|
|16:25:04.084|Found a .tool-versions file. Installing dependencies.|
|16:25:04.828|cmake plugin is not installed|
|16:25:04.849|java plugin is not installed|
|16:25:04.883|redis plugin is not installed|
<and a few other plugins>
|16:25:04.919|Error: Exit with error code: 1|
|16:25:04.920|    at ChildProcess.<anonymous> (/snapshot/dist/run-build.js)|
|16:25:04.920|    at Object.onceWrapper (node:events:652:26)|
|16:25:04.920|    at ChildProcess.emit (node:events:537:28)|
|16:25:04.920|    at ChildProcess._handle.onexit (node:internal/child_process:291:12)|
|16:25:04.935|Failed: build command exited with code: 1|
|16:25:06.020|Failed: error occurred while running build command|
2 Likes

I’ve just run into exactly the same issue.

Also hitting this issue. I’m deploying from a monorepo that also contains dart and flutter, which are included in .tool-versions. They’re irrelevant for the Pages build, but cause the build to fail with “plugin missing”.

It would be great to have this or rather be able to configure this or ignore specific items

+1 on this one