How to connect hostname properly

I need help getting these paths to resolve: predictiveux. com and http://predictiveux.com

It seems that www.predictiveux.com resolves as well as https://www.predictiveux.com, but not the two above. My domain name was purchased through GoDaddy and my site is hosted on Hubspot. I am using Cloudflare and am unable to figure out how to get those URLs to resolve.

A lot of people type predictiveux.com into the browser and then email me to let me know my site is down. I have looked many times at the documentation here and at GoDaddy, Google, Hubspot and it just doesn’t make sense to me what I am supposed to do to get this to resolve.

Hubspot says my domain isn’t hosted there which I get because it’s at GoDaddy. GoDaddy says my domain isn’t managed there because it’s at Cloudflare. I also get that and can see Cloudflare nameservers are showing at GoDaddy and obviously resolve some URLs but not all the desired paths. I just don’t get what I am supposed to put in the A Name to get the other paths to resolve. I don’t know how to find an IP address that isn’t a route back to Cloudflare.

Can someone please explain to me how to fix this in simple terms? I think I need to add an A name, which I did previously, but it said my domain was basically a circular reference because the domain IP I found was from the reverse proxy at Cloudflare.

So confused and frustrated.

Thanks in advance!
Karen

PS I did try to find the IP address using a 3rd party tool, but it keeps pointing to the Cloudflare IP address…so I guess the big question I have is how do I find the IP address I need in order to add a resolvable A Name record?

Hi Karen

It seems you need to configure redirect HTTP to HTTPS

For do this you need to login in Hubspot account and do this:
Go to Settings (gear icon) > Website > Domains & URLs > Domains tab > Edit > Update domain security settings > Require HTTPS (flagged) > Confirm.

Let me know if it was helpful for you

Mirko

Thank you for the suggestion, great idea. I have made those updates and am still getting a 1016 error.

You should have an address from your web host (Hubspot) that you’re supposed to point to. Your www DNS entry is set up correctly. Your DNS entry for the root domain should point to the same address that you now have www pointing to.

Thank you for your reply! :slight_smile:

I went down that path, too and found that Hubspot doesn’t provide an IP address per the thread here:

I am not sure what to do next. Do you think this is a Hubspot issue?

You could potentially fix this with redirect rules at Cloudflare.

This will result in traffic destined for example.com to be handled by Cloudflare which will use the redirect rule to send it to www.example.com.

Thanks for the suggestion. Cloudlfare is saying either validation error or that IP is already in use, depending on what IP address I try.

I am going to try to contact HubSpot to see if I can get an IP address from them.

Thank you so much! I will update here if/when this gets resolved.

That thread on the Hubspot forum says they use a CNAME rather than an A record. That’s fine. You can, at Cloudflare, create a CNAME for your root domain entry.

Your www record is working, so just put whatever is in that entry in a CNAME for the root domain (just enter @ for the name field).

2 Likes

Thank you for the suggestion. I tried it and it says “host already exists” - here is what I did:

  1. Edit CNAME record for www
  2. Copy the Target address
  3. Create new CNAME
  4. Set Name as “@” for root
  5. Paste the Target address from Step 2
  6. Select Save

This results in an error “An A, AAAA, or CNAME record with that host already exists. (Code: 81053)”

I also tried to create A records pointing to the IP address from Hubspot but it won’t work.

I am thinking at this point that I need to move my domain name off of Cloudflare. I don’t want to do that, but I can’t figure this out.

So there is already a record for the root. In your DNS control panel there is an entry for predictiveux.com What type of record is it and what does it point to?

Hubspot may want that record to be :grey: instead of :orange: in which case you can simply edit the record to be be :grey: if needed.

Right now there is a record but it appears to point to the ‘wrong thing’. I am not sure what that thing is, but if it is an A record now, as others have mentioned you might want to replace it with a CNAME. So you’d need to delete the A record for predictiveux.com and then add a CNAME per the instructions above.

Thanks for your advice and questions.

There is an entry for the root domain. It is a CNAME record and points to a Hubspot subdomain address that I hoped would redirect to my website because it’s the same address I am using for the www record which does redirect/resolve to my website. Basically, my website loads if I go to the www leading me to think that CNAME record is set up properly, but it does not load when I go to my domain name without a www leading me to think the CNAME record for that one is not set up correctly even though it matches the one that resolves. Both are proxied (orange cloud). I just turned off the proxy to see if that helps.

I don’t have any records for A because I could never get a proper IPv4 address from Hubspot to make that work. However, I did find a way to get to a an IP address in Hubspot by starting to set up a domain redirect. Unfortunately, when I entered the IP address from that into the A record I go the error that host already exists for another record.

Not sure what else to try.

Sorry if this post is worded in a confusing way. I was trying to work around the 4 URL limit for new users. This comment tool was making links out of a bunch of words so I had to re-write this in clever ways to remove those links and it came out kind of confusing…lol

When you add a CNAME for the root domain, there mustn’t be another CNAME for it, nor any A or AAAA records for it. Right now, it looks like you have a CNAME for www, and there is something for the root domain that is set to be proxied. Whatever A, AAAA, or CNAME record(s) exist for that, delete them, and add a CNAME for it just like you have for www.

Is it possible for you to share a screenshot of your DNS settings, or will the forum not let you post images?

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.