How to configure a port in cloudflare

I reviewed the following article

https://support.Cloudflare.com/hc/en-us/articles/200169156-Which-ports-will-Cloudflare-work-with-

According to the article I can use one of those ports to connect with Cloudflare proxy, I have a server with one of those ports enabled but I can not see it working, and add my IP to Cloudflare.

Someone could provide me with a guide to how this configuration works, I am using an EC2 instance of AWS.

Thank you!

The port in your browser will correspond to the port CF goes to, so

https://example.com:443

Will go to the origin’s port 443, and:

https://example.com:8443

will go to the origin’s port 8443.

Hello, thank you for your quick response.

in this case I am using the port “2053”

when I try to enter

https://example.com:2053

This does not work for me

but on my server this is already enabled.

Any idea why it does not work?

What error do you get? A Cloudflare error, or perhaps a browser error? (screenshot would be best)

thanks for your reply again

on my AWS server this port is enabled and works correctly, but in Cloudflare I do not understand why it does not work

Ah ok, see this article for in-depth analysis: https://community.Cloudflare.com/t/community-tip-fixing-error-525-ssl-handshake-failed/44256?u=judge

Since that is an SSL port, you do need to set up TLS and have an actual SSL certificate on your server. IIRC Flexible SSL mode doesn’t affect how SSL works on the other ports.

If you use an AWS load balancer or API gateway, you can get a valid certificate for free in the certificates manager (however, if you are not using an ELB, API gateway, etc. I would not recommend you start using them just for this).

If you’re using a plain ec2/lightsail instance, you can get a free certificate from LetsEncrypt, or use an Origin Certificate from Cloudflare

https://support.Cloudflare.com/hc/en-us/articles/115000479507-Managing-Cloudflare-Origin-CA-certificates.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.