How to completely disable automatic deployments?

I previously had Cloudflare Pages integrated with my Github repo & organization and it was building my Docusaurus site. However, I have since switched over to publishing from a Github Action in my repo, and no longer need Cloudflare’s deployments.

I edited my Cloudflare Pages project to disable automatic deployments, but in the main UI it says that it is “Paused”. I even deleted the Cloudflare Pages github app, and it still says it’s paused. Attempting to resume it now gives an error because access was revoked to Github.

Why does Cloudflare Pages show that deployements are just “paused”? I want them to be completely disabled. There is an annoying “Click to resume deployments” banner that I also want to get rid of.

Do you not see these options under SettingsBuilds and Deployments

Yes, I already had them disabled:
image

But I still get this banner:
image

Ah, then the only to disable the deployments and remove the banner is to change the project from git integration to direct upload. You’ll have to delete the project and recreate.

@Cyb3r-Jak3 One follow up question: I deleted & recreated the project but it says that “main” is the production branch. However, I need “master” to be treated as the production branch. I don’t see a setting to change this. How do I change it to ‘master’?

I am using the Cloudflare pages action in a github workflow:

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.