How to clear cache for the Cloudflare CDN

Good day,

I just start using Cloudflare this week to use the CDN. Since my origin server is located in USA, but my target location is at Southeast Asia. However, once I start using Cloudflare CDN and argo. it isn’t faster at all or it actually got slower…

In this topic, I wish to ask if I have use Cloudflare CDN correctly to improve my website thaigood4u .com server response time. Since I start using Cloudflare CDN, somehow the website speed is only a bit slower than before… I even already purchase the Argo as well, and the speed isn’t changing.

Before I start using Cloudflare the server response time is about 2.8s but now its above 3.5.

However, when I test at Private page it actually only takes 1.06 second. So, is this perhaps a cache problem? In that case, how do I fix the cache for all the browser that has browse my site?

When I test with KeyCDN. it just show that the speed remains the same as old. I even use keyCDN test, and the test result is still the same. They all are this difference; this just proves that I haven’t use Cloudflare CDN correctly.

here’s the screenshot of my KeyCDN:

(I can’t post all screenshot but only one, since I’m new user)

Answer these questions to help the Community help you get started.

What is the domain name?

Have you searched for an answer?
Yes, I’m looking around articles, but still confused and hard to understand… so I was wondering if I can just ask here directly.

Please share your search results url:
I swear can’t send those links even with ``…

When you tested your domain using the Cloudflare Diagnostic Center, what were the results?
So I test at multiple sites such as Gmetrix, Page Speed, and at KeyCDN.

Describe the issue you are having:
Using cloudflare CDN even with Agro smart isn’t improving my website performances

What error message or number are you receiving?
Nothing error. just slow performance

What steps have you taken to resolve the issue?

  1. I have purchase the Agro, though it’s needed for the CDN connection.

Was the site working with SSL prior to adding it to Cloudflare?
I dont use SSL at cloudflare

What are the steps to reproduce the error:

  1. To fix the cache (?)

Have you tried from another browser and/or incognito mode?
Yes, it actually only takes 1.06 second.

My apologies if my question have any inconvenience. I thank for your time and support.

1 Like


I’d suggest you familiarize yourself with how Cloudflare works, and especially how caching works, so that you can make the best use of the several Cloudflare tools available to better the performance of your site.

Before writting this topic:

  1. I have enabled Tiered Cache with Argo.
  2. Auto minify
    3, Brotli
  3. Rocket Loader
  4. purge my cache

And yet it’s not faster at all,

Those articles aren’t solving my problem. It looks like my problem was that my website is still redirect to the Origin server route, not the nearest CDN server. How to make my website to route to the nearest CDN server?

And I’m not sure why, I already clear my browser cache but it still the same speed… it’s only faster when I use private page.

Just in case, the browser Im using is Microsoft Edge

Cloudflare caches static files by default, but that does not include HTML pages, which may contain dynamic elements, such as login details, user names, e-commerce cart info etc. Without caching HTML, even a non-logged-in visit will be fetched from the origin, defeating your original intention to bring your site closer to visitors.

If you want to cache HTML for non-logged-in visitors, Cloudflare offers a few options. One of them is APO for WordPress (paid add-on on Free Plans, available as part of paid plans), which does it all automatically. Another is Cache Rules (Beta), which can be used to cache HTML but you’ll need to understand how your origin sets its Cache-Control and create the rules accordingly, with option to bypass on cookies and other settings.

How do I cache it as well for logged in visitors…? And why we can’t just use Purge Cache to solve this??

Do I need to have custom nameserver to use APO for WordPress?

Please refer to the links I posted above. Without some familiarity with caching in general and how Cloudflare works it makes little sense trying all buttons to see what works. Purge Cache, as the name imply, will immediately purge the cache… but only if it exists.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.