How to change name server?

Recently I moved my domain from Namecheap to Cloudflare.

Now I don’t know how to change the Nameserver on Cloudflare. I host my site with another hosting provider. and cloudflare is not detecting my hostings nameservers. how to add it manually to the Cloudflare domain then shift to Cloudflare CDN later?

If you’re talking about the domain registration itself, Terms of Service 6.1 prohibit changing name servers away from Cloudflare.

If you need further assistance, please post the actual domain name.

here is the domain name:

if its prohibited then how i should connect my hosting with cloudflare CDN?

I see your domain is using Cloudflare’s Anita and Camilo name servers, and resolves to an IP address at Namecheap.

The server looks to be using a Cloudflare Origin Certificate, which is good, but your DNS Entries for and www need to be set to :orange: Proxied.

It’s already set up like that.

I m not sure how to make this work.

At the bottom of that DNS records page, does it show Anita and Camilo as your Cloudflare name servers?

yes it does

Something is strange. WHOIS shows you don’t have DNSSEC enabled on the domain, but an actual test shows it’s active.

If you scroll down a bit on that DNS page, what does DNSSEC say? Enabled? If so, please try to disable it.

If I click through the Origin Cert warning, cPanel doesn’t load the site. Most likely because it’s not properly configured for HTTPS.

Will your host provide an SSL certificate for your site so you don’t have to use the Cloudflare one?

yes they provide an SSL if Cloudflare doesn’t provide one.

Try that. That should at least get something working.

Did you try the DNSSEC suggestion?

but for that SSL i need to change the nameserver. and I think I m not allowed to do that.

and what is DNSSEC?

DNSSEC is a locking mechanism for DNS that stops anybody else from providing DNS for your domain.

Please make sure it’s turned off in your DNS settings page.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.