How to allow no user agent when accessing my site?

Answer these questions to help the Community help you get started.

What is the domain name?
hamishmb,com

Have you searched for an answer?
Yes

Please share your search results url:
Couldn’t figure out how to do that seeing as the search bar doesn’t open a page with results.

When you tested your domain, what were the results?
I get a 403 Forbidden error message.

Describe the issue you are having:
A program I wrote accesses my website to check for updates at https://www.hamishmb.com/files/updateinfo/ddrescue-gui.plist but unfortunately that has stopped working recently with 403 errors being returned instead. When I specify a user agent, everything starts working again. I will be happy to supply a user agent for future versions of the program, but I wouldn’t want all my current users to miss out on the update because of this issue.

Is there any way I can bypass this and revert the behaviour back to how it was before (requests allowed)?

What error message or number are you receiving?
403 Forbidden

What steps have you taken to resolve the issue?

I attempted to create a new WAF rule to skip when the user agent was unspecified for that URI, but it didn’t seem to do anything.

Was the site working with SSL prior to adding it to Cloudflare?
Yes.

What are the steps to reproduce the error:

  1. Access the URL above without using a user agent and observe a 403 Forbidden error message.

Have you tried from another browser and/or incognito mode?
N/A

It sounds like your program might be getting block by a built in WAF rule. You should check your WAF events and see if you can find the rule blocking your program and add an exception for it.

Nothing related to this seems to be showing up in the WAF events page, any other suggestions?

I’d make a new skip rule for the IP your program is coming from. Easiest way to skip issues

Unfortunately that won’t work as the program is running on thousands of different clients’ PCs across the world. Can I just disable the WAF firewall or something?

Sure. You can add a bypass to the specific urls/host or turn the security setting down to low. But if you’re not seeing any events in your WAF then it could also be something else going on that is blocking it.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.