How to Allow Bots Search Engine on Page Rules? Please hlep!


How do you set the Page Rules so that search engine bots like Google, Bing, Yandex and Yahoo aren’t blocked by WAF or page rules?

how do i set it up?

1 Like

Bots aren’t blocked by default. Did you add something that’s blocking them?

Yes. I blocked IP from USA. and Googlebot is also blocked.

Yes. I blocked IP from USA. and Googlebot is also blocked.

With in you can implement this slightly leaner and I also took the liberty to add the bot check

( in {"CA" "CN" "GB" "IE" "RU" "TT" "US"} and not



Is the setting like in the picture, bot search engine Googlebot, Yahoo and Bing will not be blocked?

Doesn’t quite match the screenshot from @sandro, it is shown there with ‘AND’ not ‘OR’ known bots - OFF

1 Like

What is true like this screenshot?
If I’m setting like a screenshot, is it sure that boot isn’t blocked?

Should be, that rule should block all traffic from the listed countries unless it is a known bot.

1 Like

Is that rule the same as the one posted earlier?


Thanx you @sandro and @domjh

After I blocked IP by Country. My site’s domain cannot be shared on Facebook,com.

I tried to share one of the posts on the site to Facebook,com, but it couldn’t, there was a notification like this -> Access denied | used Cloudflare to restrict access.

How do you overcome this problem?

This is Screenshot for Notif:

Facebook is using IP Addresses in the US. You blocked access from the US.

Yes, I know it.
Well, how do you overcome this problem?

Remove “US” from the block list in your Firewall Rule. But keep in mind that you’ll have to allow US traffic.

There’s always the chance Facebook is using a consistent User Agent you can permit, but I don’t know what that would be.

I believe that to be facebookexternalhit/1.1 (+, however keep in mind by unblocking a specific user agent you’d allow everyone to access your site who claims to have that user agent.

The more secure solution would be to additionally exclude the Facebook crawler from the block. Unfortunately it appears to come from a plethora of addresses, so the easiest approach would be to exclude the entire Facebook network. Disclaimer, will also mean Facebook employees will be able to access your site however too.

In order to implement this simply change your rule into

( in {"CA" "CN" "GB" "IE" "RU" "TT" "US"} and not and ip.geoip.asnum ne 32934)

Is the setting like the screenshot below correct?

( in {“CA” “TT” “GB” “US” “CN” “RU” “IE” “RO” “NL”} and not and ip.geoip.asnum ne 32934)