How to add site when i don't get + add site button?

I have created a free account. I tried to add a site but don’t see +add site button. I clicked on website and get started button. Which redirects me to same select an account but I don’t see or have any account to select.
I even tried to submit request through cloudflare by support portal which ends up in same page for select an account.

Can you please help me add site and create an worker. Or what account to search select here where I don’t have one?

Sorry for the issues. If you are still encountering this issue, can you try to:

  1. Log out of your Cloudflare account.
  2. Clear your browser cache and cookies.
  3. Log back into your Cloudflare account.
  4. Look for the “+ Add Site” button at the top of the Cloudflare dashboard.

If the button still does not appear, try using a different web browser or incognito mode. If the issue persists, please open an Account ticket with Cloudflare Support and share your ticket number here. I’ll flag it for my colleagues in Support.

You can open an Account ticket here,

@cloonan Thanks for the reply. I tried all. Using different browser, clear cache, use incognito window, nothing works.
The support link( support portal) also ends up in same select an account page for me, as i said in original post.
Nothing seems to show add site button. Somehow the my cf account considered to have accounts which I don’t. And everything I try ends up in select account page.

1 Like

Sorry for the issues. I created ticket 3033010 on your behalf and you will have received a copy of it. You can communicate with the Support team privately on that ticket.

1 Like

Thank you very much @cloonan. I received an email with the ticket you have created. I replied to that with the information. I greatly appreciate you creating a ticket for me.


Looking into it! Will work with you there. :smile: :+1:t2:

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.