How long to propagate?

How long does it take to fully propagate after changing the Nameservers DNS to Cloudflare?

The usual time. Most of the time within a few hours, sometimes up to several days.

Whats your domain?

1 Like

Hi Sandro

rediscoveryofme.com

Many thanks

Hi @chris.hiiinds,

Your nameservers appear to successfully point to Marge and Clyde nameservers. Are these the ones asked for in the account?

They do look to still be propagating, a few locations still show ns1 and ns2 from Bluehost.

How long ago did you change them?

I changed them at 10am but only just for www

They can take up to 24hrs, so that’s not unusual… You do have to change the authoritative nameservers for your entire domain, not just the NS records, however it looks to me like it is done correctly :slight_smile:

1 Like

Thanks a lot domjh

1 Like

Hi

I still have this error message, how do I resolve? Do I need to do anything to resolve?

MX record is pointed to your origin server exposing your origin IP address.

If your mail is on the same server as your website then there isn’t really anything you can do about it.

Thanks again domjh

1 Like

Still not live yet

That is odd… There still seems to be one or two locations that see the Bluehost nameservers. If you hit ‘Re-Check’ in Cloudflare, does it still ask you to change the nameservers from Bluehost to Cloudflare?

Where do I recheck please?

If Cloudflare still say that your nameservers don’t point to them then on the overview tab of your dashboard, where it asks you to change them, there should be a ‘Re-check Now’ button.

Or has it accepted the nameservers and are we now talking about a different issue?

It says this on the overview

Great news! Cloudflare is now protecting your site

Also what is curious is it is saying there has been traffic for the last 6 hours but I can’t see anything on GA?

Excellent, that means that the nameservers have propagated and Cloudflare is now working on the site.

The traffic there is reported slightly differently to GA:

I now see a too many redirects error:

The errors “The page isn’t redirecting properly” or “ERR_TOO_MANY_REDIRECTS” indicates a redirect loop between Cloudflare and your origin server. The easiest fix for this is to remove the redirect on your origin server. For a more detailed set of options, review the troubleshooting suggestions in this Community Tip. Let us know if you continue to see issues after trying the Quick Fix Ideas in the Tip, we’re happy to help further.

The most likely cause of this is that your SSL mode is set to Flexible which can cause this issue as well as not being secure. Making sure you have a certificate installed with your web host and changing that mode to Full (strict) should both make it secure and fix this issue if it is the case.

Sorry, this is where I get lost, where would I ‘Remove the HTTPS redirects in your origin server.’?

Shall I run AutoSSL?

Is the SSL mode set to Flexible currently?

Can you get a certificate on your server? AutoSSL sounds hopeful is that will install a cert there.

Did you have SSL working before using Cloudflare?