How long for Email Routing to get set up?

I was trying to set up Email Routing for my domain lobby48.com, but after 1 hour I still got 550 5.1.1 Domain does not exist, so I reverted my DNS to my old routing provider for now.

How long does it normally take?

It shouldn’t take long :thinking: Did you set up a catch-all or custom address rule and make sure routing was enabled?

I have Catch-all address set up, and the page shown “Routing enabled”.

And the destination address has been verified?
Do you, by any chance, have a non-production domain with access to Email Routing that could be used for debugging?

Yes they were verified.

No, I don’t have access to Email Routing on any other domain.

I suggest you try the following:

  1. Export your current DNS records so you can restore in case this doesn’t work. Then delete all current email-related DNS records to avoid conflict.
  2. In the Email Routing tab, click “Add records automatically”. It should now say “Routing enabled” again.
  3. Toggle catch-all off. Wait 10 seconds. Then toggle it on again. This has fixed Email Routing issues for me in the past.
  4. Wait at least 5 minutes and then send an email to your domain (preferably not from your destination address).
  5. Observe whether the email arrives or bounces. Make sure the email was actually sent to Cloudflare’s mail server and not the old provider.
1 Like

It works now. Thank you!

1 Like

Thanks @albert. Step 3 is the fix and the configuration can take up to 60s to propagate.

Hi Sven,

I’ve noticed this happening on several of my domains. Only after disabling and then re-enabling catch-all does Email Routing start working.

I’m curious as to why happens - are you able to give any insights?

It’s a known issue in the UI/API, which we are working on fixing. The UI shows all green but the routing configuration wasn’t published to the edge (where the email service runs). Turning off and on again makes the API publish the config.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.