How do you forward a domain to another domain

I have a domain (domain A) purchased through Cloudflare with a website attached to it and that’s all working fine. I purchased domain B that I want to forward to domain A, but I can’t seem to get this to work. I created the page rule but it’s been over 24 hrs and it hasn’t worked. I checked the tutorial “redirecting one tutorial to another” but it says deprecated and it looks like it takes you to a page about creating rules. Which I’ve done.

Can anyone steer me in the right direction of what else I need to do? I tried adding an A record for domain B to the IP address of domain A. That didn’t work. Not sure what else to try.

Thanks for any suggestions,

Is domain B using Cloudflare? If needs to be on Cloudflare DNS and the hostname needs to be :orange: proxied in order to perform a redirect.

You should be able to create a redirect rule based on number 3 in the cheat sheet.

3 Likes

Thank you for the assistance. Yes, both domains were purchased through Cloudflare. I turned off the page rule and instead set up a redirect rule following the example in number 3. It’s still not working. How do you proxy the hostname? I tried to Google that, but I’m not seeing step 1 do this, step 2 do that so I’m a bit lost.

Let me know if this helps.

It helped a bit as I’m getting new errors. I created an A record for domain B using the IP address of domain A. That didn’t work. I create a CNAME record using domain A as the target. The proxy status in both situations was proxied. Now (with the CNAME) I’m getting a Cloudflare error 1016 which says to check my DNS settings.

Since I don’t have hosting set up for domain B, what IP address am I supposed to be using? I can’t seem to create both A and C-name at the same time.

Don’t use a CNAME or an A record for originless redirects. Create a AAAA record for the name in domain B and make sure it is :orange: proxied. You can use the special discard prefix address of 100::.

Still not working for me :frowning:

I’m in domain B, I created a AAAA record, I entered @ for root which I assume is all traffic, I added 100:: for the IPv6 address. Proxy status says Proxied. I assume the 100:: is what is incorrect. I googled discard prefix but not understanding what I’m looking for/at. I also tried adding the IP address of domain A hosting, but that said a valid ipv6 address is required. I checked with my hosting company (GreenGeeks) to get the Ipv6 address but they said they don’t use them.

They showed me how to do a forward using them but it required changing the name servers here and it doesn’t look like Cloudflare lets me do that without a business account.

It is not. It is for the hostname that matches your domain alone, such as example.com.

It is not, if, and this is next part is important, if you are trying to configure an originless hostname. That means a hostname that has no server. When you want to send any vistors to a specific name to another web address and that name has no server of its own, it would be considered originless.

There is no hosting involved in an originless configuration. They will not have anything related to your stated objective.

You cannot do that with a business account either. The business account custom nameservers feature lets you use your own domain name to address Cloudflare nameservers. It does not allow you to use external nameservers.

If you are able to share the real domain names, the Community can provide more specific assistance. Without those details, we have covered all that we can.

Sure, the domains are no secret :slight_smile: I just thought easier to say domain A, domain B.

2 months ago, I purchased beautifulcrochet.com through Cloudflare. I have hosting for it set up with GreenGeeks. Everything is working great.

Last week I purchased the domain beautifulcrochetbyceleste.com also through Cloudflare and would like it to forward to beautifulcrochet.com.

I usually purchase everything through GoDaddy and forwarding is so darned easy, lol. As you can see, I am really struggling with Cloudflare.

So I have set up the AAAA record now using www for the name, back to 100:: for the IPv6 address. Now I’m getting a connection timed out Cloudflare error 522. Based on that error, it looks like it’s set up correctly and the issue might be the hosting? I can see in Cloudflare that it’s recording my visits to beautifulcrochetbyceleste.com, it’s just not forwarding them to beautifulcrochet.com

Thanks for sharing the domain. I see that www is resolving to the Cloudflare proxy that is good. Your apex name appears to have no entry. As long as you don’t want it to redirect, that is fine. If you want it to redirect, it will need a similar AAAA record.

On an originless setup, there is no hosting. That means that something is not correct in your redirect.

Can you share your redirect configuration?

I’m not quite sure what you mean by redirect configuration. I had a page rule set up initially but I’ve disabled that as I thought the page rules were deprecated. Screenshot attached of the AAAA setup. I hope that’s what you were referring to.

No. That part is fine. I am asking about your redirect rule as mentioned in the Cheat Sheet linked in this earlier reply.

Ah, yes, I remember setting that up.

In the screenshot of your DNS entry, you show a hostname of www.beautifulcrochetbyceleste.com, but in the rules screenshot you are matching on a hostname of beautifulcrochetbyceleste.com. That obviously will never match.

If your objective is a simple redirect from www.beautifulcrochetbyceleste.com to www.beautifulcrochet.com, you don’t need the Dynamic redirect. I also recommend against using a 301 while your are figuring out your redirect, since it is a permanent redirect and will persist after any changes are mad which makes testing more difficult than it ought to be. Use a 302 until you are certain that you have the redirect as you want it to be forever.

If you wanted to match both the www and the base name, you could use this:

(http.host eq "beautifulcrochetbyceleste.com") or (http.host eq "www.beautifulcrochetbyceleste.com")

You would need a proxied hostname for your plain domain. You can easily create that by entering @ as the hostname.

I think I’m making progress. Still not working, but it is trying to redirect. The error message now is too many redirects.

I have type = static, URL = (http.host eq “beautifulcrochetbyceleste.com”) and I also tried (http.host eq “beautifulcrochet.com”) and status code = 302

I did allow several hours between the updates since it had status code 301 previously.

Your redirect is returning the destination as:
Location: (http.host eq "beautifulcrochet.com")

You need to put the desired target URL in that redirect section. The (http.host eq "beautifulcrochetbyceleste.com") or (http.host eq "www.beautifulcrochetbyceleste.com") is the syntax for the matching part of the rule. You will want to use https://beautifulcrochet.com in the redirect section of the rule.

You still have no hostname entered for your apex name in your DNS. which means that anyone who attempts to visit without www will get a DNS error instead of a redirect.

301 is permanent, so a few minutes or a few hours makes no difference. You can use an incognito sessions as a quick fix, but you will need to tell the browser to forget about the site completely for it to lose the cached permanent redirect.

Isn’t the destination beautifulcrochet.com? When visitors go to the beautifulcrochetbyceleste.com I want them to go to beautifulcrochet.com as that’s where the website is.

I’ve cleared browser cache, opened a private window, same error of too many redirects.

No, and even if it were, that isn’t what you have in your screenshot. The destination needs to be https://beautifulcrochet.com and you have (http.host eq "beautifulcrochet.com"). Delete (http.host eq "beautifulcrochet.com") and replace it with https://beautifulcrochet.com.

HOLY MOLY! It finally worked. I wonder where I got that expression from in the first place. I am updating my notes in case I ever have to do this again for another site. I can’t thank you enough!

2 Likes

You were using the matching syntax in the redirect side. I’m glad to hear that it is working for you.

You still have no DNS record for your apex name, beautifulcrochetbyceleste.com. Don’t forget to create a :orange: proxied AAAA for it, if you want it to redirect, too.