How do I use a subdomain for the IP 51.254.31.252:8080?


#1

Hi I want to use a subdomain: profile.ender.site for 51.254.31.252:8080 how do I do that while making sure there is no port for profile.ender.site, I just want profile.ender.site to show the page http://51.254.31.252:8080 any help?


#2

Do you own ender[dot]site? While Cloudflare supports 8080 you will still have to specify it. So that you cant avoid.


#3

I own the domain, and is there no way I can hide it?


#4

You can create a page rule to forward any “standard” requests to it, but it still wouldnt be hidden. There might be a way to do this with workers, but this will incur costs.

As for the setup, you simply create a “profile” A record and point it to the address in question.


#5

Alternatively you could also embed the port 8080 URL into a fullpage frame that you embed at the regular port 80 URL. Not too elegant however.


#6

Hmm it sent a invalid request, I used SRV records and an A record, but doesn’t work https://profile.ender.site:8080/ nor does https://profile.ender.site


#7

8080 is not HTTPS but HTTP. Can you post your DNS settings?

Currently you send a redirect to https://site and that wont work. You need to remove that.


#8

??? wdym


#9

https://hastebin.com/ecatigahux.sql here is my dns


#10

Your DNS setup looks okay but, again, you are still redirecting somewhere. Either on your server or at Cloudflare. You need to remove that redirect.


#11

what am i redirecting to though


#12

To the HTTPS version of that page on the default port. Please check out the browser developer tools and you will notice the redirect.


#13

ok where


#14

alright I can see it redirect when I type http://profile.ender.site:8080. it does not redirect when i go to http://profile.ender.site


#15

It actually does too.


#16

what is going on then


#17

See:

You cannot use https with port 8080. You will need to set up your web server to work on port 80+443 or On one of the ports from that article, something we can’t help you with.


#18

I will try 443 then


#19

Thats what I mentioned above but the issue doesnt seem to be the port but the redirect.


#20

yeah my issue is I can’t use port 443 on my web server it just crashes