How do I update my PHP

I recived an error message on my site that said, “WordPress has detected that your site is running on an insecure version of PHP”

How do I update this? How do I check the PHP version I am using?

Thanks for your help!

I am afraid that is a question for StackExchange or any other server administration related forum, not Cloudflare. You might also want to ask your host if they maintain your server.