How do I update my old favicon showing up when Cloudflare is checking myu connection

I updated my favicon a month ago and the old one is still showing up

Where is the favicon located? Under some sub-directory or under /home/ or /public_html/ or /www_root/?

Favicon filetype extension (ico, png …) should be cached by default as stated:

Furthermore, may I ask have you tried purging the resource URL via Cloudflare dashboard → Caching → Configuration → Custom Purge? :thinking:

If not, give it a try.

By default, it’s set to “4 hours” to keep in a visitor’s Web browser.

May I ask you to check out what option have you got selected by navigating to the Cloudflare dashboard → Caching → Configuration → find section “Browser Cache TTL” and make sure the selected option from the dropdown menu is “Respect Existing Headers”.

Otherwise, may I ask if you’re using some custom Page Rules?

May I ask have you tried using a different Web browser, or tried clearing your Web browser cache?
How about using a Private window (Incognito mode) or a VPN connection if possible?
Is it the same behaviour on your mobile phone (4G LTE, mobile data, cellular)?

This helped me. Add “?v=2” to the end of the URL for your favicon.ico:

<link rel="icon" href="" />

It is recommended as a “temporary” solution as this will cause an increased server-load on large sites by always looking up the favicon.