How do I fix this? An A, AAAA or CNAME record already exists with that host. (Code: 81053)

I’m trying to add this CNAME record but it keeps saying “An A, AAAA or CNAME record already exists with that host. (Code: 81053)” How do I fix this?

You must have another DNS record that is an A, AAAA or CNAME record for your root domain. You can’t have more than one.

I have never seen that before… When I do a DNS lookup on that domain, I see 5 Cloudflare IPs as A records instead of the normal 2… @cloonan… Is this normal behaviour?

@domjh, I’ve seen multiple A records for round robin when the load balancer is active, but that’s not the case here. @michael.carels, here is the only detail I’ve seen on that error, “If you see the error “An A, AAAA or CNAME record already exists with that host. (Code: 81053)”, it means either the CNAME record you are trying to add is for SSL verification for a partial setup and the zone is on a FULL setup; there is no need to add the CNAME record for SSL verification. Or, it means a DNS record with the same name already exists and needs to be deleted before you add a new record.” I visited the site without issue, are you adding the record to address an issue you’re seeing?

1 Like

AFAIK that’s the typical case when someone uses a CNAME to point the root domain to some service (Clickfunnels is the typical case, like also here) which is also on Cloudflare and hence cant be proxied but is flattened because of the CNAME. In that case you simply resolve the original addresses.


I have a similar problem. Can I ask about it here or should I start a new topic?

I’m trying to add a CNAME record and getting the error message, “An A, AAAA or CNAME record already exists with that host. (Code: 81053).” but there’s not another CNAME record the same listed in my DNS records. I’m a complete novice and I’m following someone else’s information to connect my domain to my Kajabi.

sandro says: [quote=“sandro, post:4, topic:57709”]
In that case you simply resolve the original addresses.

How do I do that please? Thanks for any help you can give me.

Hi @jinksy9,

If your post needs moving to a new topic, the Mods or MVPs will do that :slightly_smiling_face:
Generally it is better to open a new topic unless it is exactly the same issue.

Are you able to post a screenshot of your DNS records (Redact IPs) so we can see what the conflicting record is there?

Hi domjh, here’s screenshot of my DNS records in Cloudflare. I’ve masked my actual domain name. image

Hope you can see them ok. There’s no other record the same though.


Hi @jinksy9,

Thanks for the screenshot. The reason you see that message when trying to add the record is due to the AAAA records at the top of that list. You can’t have an AAAA and a CNAME record for a host, i.e. you can’t have the AAAA record already there and the new CNAME that you want to add.

Those AAAA records should point to your current web host, however if you want to change to use Kajabi, you will need to delete the AAAA records and you should then be able to add the required CNAME.

I hope this helps!


Hi again @domjh. Thanks for your help with this. I was wondering about the A and AAAA records as they all point at 1&1 IONOS - that’s who I registered the domain with, it’s not hosted anywhere as such just ‘parked’ with 1&1 IONOS at present. I’ll give it a go :slight_smile: Thanks again, J

1 Like

No problem. If the domain is parked, it is likely that those records from 1&1 are to show a landing page for the domain. You should be OK to remove tham and add the CNAME you wanted.

1 Like

Hi again @domjh. Just to say thanks again. It worked :slight_smile: I deleted the 2 AAAA records but still got the same error message so deleted the 2 A records as well and then it worked to let me add the CNAME record. Many thanks for your help. You’re a :star: :smile:

1 Like

Thanks! No problem, happy to help @jinksy9. Glad it all worked for you.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.