How do i edit my origin server to fix a redirect loop

I do not have the knowledge yet to fix this problem and am hoping you could help me with this.


  1. My domain is managed by siteground and pointed to Cloudflare
  2. I use Cloudflare nameservers and DNS records
  3. My website is hosted on Webflow
  4. I have tried changing the SSL strictness from flexible to full, it did not work
  5. Webflow provides an SSL certificate by default


Cloudflare support suggests doing a few technical things I may be able to learn to do, but what stumps me the most is editing my origin server. I do not know how.

Please could you help me with this.

Webflow looks like fully-managed hosting–that is, you’re not doing server administration.

If they provide SSL by default, try Full Strict mode and see if it Just Works. If it doesn’t, something isn’t set up properly at the host’s end for SSL. What you want is, first, for it to work with SSL if you bypass Cloudflare completely. Once it does, enable Cloudflare in Full Strict mode.

How do I bypass Cloudflare, do i pause Cloudflare or unproxy my DNS records?

Either way… pausing essentially un-proxies all your DNS records for the domain temporarily (but you’ll still see them as orange-clouded in the control panel)

Either way, wait 5 minutes before testing

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.