How do I change name servers?

I registered a new domain with Cloudflare, but I cannot change the name servers. Here is a screen grab of the changes I made to the A record, but this does not seem to change the name server. Please help.

Can you explain what exactly you are trying to do and also tell us what your domain is?

You are mixing up a few words that don’t really go together.

Cloudflare does not allow you to change the nameserver of a registered domain if that is really what you’re trying to do. You need to create all required DNS records directly in Cloudflare.

Otherwise, if you really wanted to create an A record, what you did looks fine to me.


Thank you for your response. I am trying to point my domain to my hosting provider. I assumed that cloudflare would allow me to do that, as most registrars do. Now it seems like changing the A record is not the same as changing the name server record for a domain.

Is it the case that registering a domain with cloudflare limits one to cloudflare for hosting? If not, how do I point my domain to my hosting provider? If yes, then I’ll transfer the domain to another registrar in 60 days.

I’m about a decade removed from this lingo, so thank you for bearing with me.


No. You would create an A (or AAAA) record to point the domain to your webhost, just like you did. Your host will usually supply you with a list of records to add here, as there are usually other records needed.

Changing the nameservers would allow your webhost to create the required records for you automatically, but this is not compatible with Cloudflare.

What error do you see when you try to open your domain in a browser?

1 Like

Ah, that is starting to make sense. I have verified with traceroute and ping that the domain resolves to my hosting company’s name server ip addresses, but now I realize that I need to point then to my server’s IP address. Let me try that.


1 Like

Ok. Pointing the A record to my specific server’s IP worked, but my hosting cpanel still doesn’t recognize the domain in order to add it. Ping works with the domain now. Since I have a hosting service for the average consumer, I may be better off with another registrar.


Try setting the A record to :grey: DNS Only if it is currently :orange: Proxied. You may be able to set it back once your cPanel recognizes the domain.

Thank you for your reply. I have both A record and CNAME record pointing to my server, but the control panel still complains. The provider’s record says that A record should be enough. Sounds like a bug in control panel. I’ll check with the hosting provider and update this thread.


Are those records :grey: or :orange: ?

Ah, sorry. Both records are NONproxied. (Gray cloud).


1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.