How can I use strato mail with cloudflare?

Hey everyone!

I’m using cloudflare on my domain for protection and some of the other features. But when I proxy my website through cloudflare I cannot use my strato mail anymore, any emails just refuse to send and recieve. I contacted strato about it but they were unclear about a possible solution and it seems like they kinda don’t care? I’m wondering if anyone has found a solution for this or knows how I can possibly solve this, I’ve been paying for the email feature and not being able to use it just sucks.

  • Lucy


Can you maybe share a bit more about how your email setup works and what your domain is?

Generally, if you want to receive emails, the target of your MX record should not be proxied.

However, this would not influence your ability to send emails, so you might have some other problems as well.

Could you try to see what the problem is? It works by simply sending an email to them.

1 Like

Hey Laudian!

My domain is and I’m trying to send/recieve emails from [email protected] (creating other mail addresses gives the same issue.)

I think that I was a bit unclear, I haven’t proxied the MX records. Also the only MX records that I have for my domain are from mailtrap (from a project that I’m working on). There are no other MX records and searching on google I wasn’t able to find the official strato MX records.

When in contact with strato they told me that it is because I proxy my main domain through cloudflare, if I remove cloudflare it does work but I’d like to not do that for my safety and some of the features cloudflare provides.

This is the link to my result of mail-tester

And this is a screenshot that I took of it

Right now, I can see the following MX records for your domain:

dig +short mx

This indicates that you have enabled Cloudflare’s Email-Routing feature. You need to disable this if you want to use your Strato email.

Mail delivery works as follows: The sender will check for an MX record on your domain and send the emails to whatever address is specified in the record.
If no such record is found, the sender may instead try to deliver the mails to your domains A record.

If you proxy your A record, this cannot work, as Cloudflare only proxies HTTP/S traffic.

So After disabling Email-Routing, you should unproxy your record. This will show a warning that this exposes your IP address, but that cannot be avoided if you want to use your server for email.

Then you should create an MX record for name @ and content, to tell others where emails should be delivered to.

Next, you need to create a TXT record for SPF. It should have name @ as well and content v=spf1 mx -all. This would allow the address named in your MX record to also send Email. Depending on what address Mailtrap uses, you might have to include them in your record as well.

Then, to solve the DMARC problems, there are 2 options I would recommend:

  1. Delete both of your existing DMARC records and enable Cloudflare DMARC management.
  2. Delete only the record that contains your private email address and edit the Mailtrap DMARC record from p=none; to p=reject;

When you have done all this, you can try mail-tester again, as well as just try to send and receive emails.

Thanks for the quick response!

I tried all your steps but I’m still getting the same issue. I wasn’t able to reran the mail-tester again since I have to pay? But I did find an other website that sort of has the same functionality

I’ll have another look later when I get home, these things are a bit tedious on a small phone screen.

alright, thank you!

Ok, I currently see 3 problems:

  1. You still have 2 DMARC records. You HAVE to delete one of them, you cannot have more than one. I would still recommend deleting both and using Cloudflare’s DMARC management, but deleting either one will work as well.

  2. Please change your SPF record to v=spf1 Combined with 1), this should allow you to send emails.

  3. The record resolves to xxxxxxxxx. Is this the same IP that the A record for resolves to? As you were able to receive email on that record, I assume it is not the same?
    Sadly, Strato isn’t very forthcoming with information on how to set things up.

I tried your steps and I am able to send emails now. Recieving sadly still doesn’t work.

To come back to your third question, both have the same IP adress that they resolve to. Also could you please edit/remove the comment if possible since I’d like that IP to not be available on an community post on the internet :upside_down_face:


To receive emails, it might be a good idea to just ask Strato about the correct value for the MX record.
After a quick search, I was able to find some older values, but nothing that was up to date.

It is really curious that Strato does not publish these in their documentation.

yeah the support isn’t the best. I’ve already contacted them about the mx records multiple times but they’re just not giving them out for some reaon? That’s why I went on here for hopefully an answer. I could transfer my domains but I have a couple now and that would be a hassle.

Which older values did you find?

You could also have a look at .
Your old MX records from before you activated Cloudflare Email-Routing should be in there somewhere.

1 Like

Thanks! I looked at those logs, and now I am able to receive emails. It is still very delayed and it takes a while for the emails to arrive but it does work now. Thank you so much for your help!


This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.