How can I resolve a 525 error for my glide app on a subdomain of my website?

Hello. I have this error when I try to access my site, which is a glide app that lives on a subdomain of my website. Thank you!

Hi @meredith,

A 525 error is typically caused by a configuration issue in the origin web server when its SSL certificate is not properly set up. Review the suggestions in this Community Tip for advice & insight.

As for how you fix it in your scenario, I am not sure. You need to make sure that your site has a valid certificate and it working with HTTPS, before using Cloudflare on it. If this is not possible or your host charges for a certificate, you could install a Cloudflare Origin Certificate there.

1 Like

Thank you @domjh. I ended up changing the encryption mode to flexible. This seems to have work. I attended to try the origin CA certificate, but that’s a little over my head. Thanks, again for your assistance.

You should read:

Your host or developer should be able to help you install the certificate on your server.

2 Likes

Thank you! I was trying to save on costs, but I think I need to bite the bullet and get an SSL cert for my site. That should resolve this.

No problem, if you want your site secure then yes, you will need to get a certificate and set your SSL/TLS mode to Full (strict). Many hosts offer this service for free (or at least let you upload your own), but if yours doesn’t and you want to stick with them, I’m afraid that is the only option.

1 Like

This topic was automatically closed after 30 days. New replies are no longer allowed.