How can I put Webmin on Cloudflare's SSL connection?

Complete this information in order to ask your question.

Have you searched for an answer?

Please share your search results url:

When you tested your domain using the [Cloudflare Diagnostic Center], what were the results?


Describe the issue you are having:
I have a website that uses Cloudflare for SSL. It also uses Webmin for managing MySQL databases.

Originally, the port for Webmin was ADDRESS:10000 and I would log in using a web browser going to that address. However, I was receiving error connecting messages.

So, using SSH, I changed the port from 10000 to one of those allowed by Crashplan for SSL connections. I still received errors trying to connect through a web browser. Finally, I used SSH to turn off SSL connections for Webmin, changing the 1 to a 0. I was then able to get through to Webmin with a browser, but it’s an unsecured connection

Now, I want to know: is it possible to set up Webmin to have a secure connection, and if so, what steps do I take?

What error message or number are you receiving?
See above.

What steps have you taken to resolve the issue?

See above.

What is the domain name?

Prefer not to share.

Was the site working with SSL prior to adding it to Cloudflare?

See above.

What are the steps to reproduce the error:

See above.

Have you tried from another browser and/or incognito mode?


Please attach a screenshot of the error:

I would recommend to pause Cloudflare and make sure your site is working fine without Cloudflare.

Once that works, it should also work with Cloudflare. Just make sure to only use the ports you already found and keep in mind that Cloudflare’s proxies only handle HTTP. If you want to connect to MySQL, you will need an unproxied hostname.

1 Like

When I pause Cloudflare, the site continues to work fine, though the http doesn’t redirect to https. However, the ADDRESS:NEWPORT only works if I specifically put in http:ADDRESS:NEWPORT. That’s the case regardless of whether Cloudflare is paused.

Does the site load fine on HTTPS when paused?

Additionally, it sounds like it’s a non-standard port you are using here (standard port for HTTPS is 443), and no SSL.

Do you have the option to change the port to 443 and add SSL? If so, I’d recommend doing that before reactivating Cloudflare.

1 Like

The OP seems to be aware of the port restrictions already, hence that reference. This will be the usual SSL issue.

1 Like

Thank you. I’m using port 8443 for webmin, which I think is okay to use based on this: [](

I think there must be some sort of setting that I’m supposed to make to associate Webmin with Cloudflare.

Again, did the site work on HTTPS?

And yes, that port will work on Cloudflare, but this will rather be a server issue. Hence, follow the advice as mentioned at How can I put Webmin on Cloudflare's SSL connection? - #2 by sandro and it should work. Do not unpause Cloudflare before your site is working fine on HTTPS.

  1. works works fine when Cloudflare is active. When Cloudflare is inactive, https will not load. Only works when Cloudflare is inactive.

  2. http://IPADDRESS:8443 (which is where my website’s Webmin / Virtualmin is located) works fine when Cloudflare is active. It also works fine when Cloudflare is inactive.

  3. https://IPADDRESS:8443 does not work at all. This is the case whether or not Cloudflare is active.

Yeah, that all needs to work without Cloudflare. Hence, How can I put Webmin on Cloudflare's SSL connection? - #2 by sandro

Alone that your server uses HTTP on 8443 is already an issue.

Again, pause Cloudflare, make sure that HTTPS works fine and then it will work on Cloudflare as well.

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.