How can I have CF just service DNS and really nothing else?

I want to bypass all Cloudflare traffic modifications and communicate directely with my apache server, in order to configure redirects and SSL without the interference of Cloudflare. I have tried to ‘Pause Cloudflare on Site’ but that also disables the DNS, so the URL doesn’t get resolved. Now I tried:

- disable proxy on DNS records A @ and CNAME www
- Browser-Cache-TTL: respect existing headers
- 'Always online': off
- SSL: off
- Automatic HTTPS Rewrites: off
- 'Development mode' on
- Purge Cache / everything
- 0 Transformation rules configured
- Completeley deleteted browser cache. 
- Flushed client's DNS cache.

I get through to http, but https URLs yield a ‘too many redirects’ error, even though I have no active rewrite rules in my server conf files.

cURL -Ia https:// runs with expected results if executed on the host via ssh. When executing locally on my client, I get a lot of CF stuff I don’t understand (and don’t want):

HTTP/1.1 301 Moved Permanently
Date: Sun, 01 May 2022 08:32:29 GMT
Connection: keep-alive
Cache-Control: max-age=3600
Expires: Sun, 01 May 2022 09:32:29 GMT
Location: http:///
Expect-CT: max-age=604800, report-uri=“https://report-uri.cloudflare.com/cdn-cgi/beacon/expect-ct
Report-To: {“endpoints”:[{“url”:“https://a.nel.cloudflare.com/report/v3?s=…”}],“group”:“cf-nel”,“max_age”:604800}
NEL: {“success_fraction”:0,“report_to”:“cf-nel”,“max_age”:604800}
Strict-Transport-Security: max-age=15552000; includeSubDomains
X-Content-Type-Options: nosniff
Server: Cloudflare
CF-RAY: …-AMS

That seems weird. Pausing Cloudflare is supposed to disable proxying on all records but keep serving DNS. Could you share the domain and then try unpausing again?

Just set the DNS record in question to DNS Only :grey:. All other settings are irrelevant once you do that, and requests go directly to your Origin.

1 Like

My fault. I had to wait longer for DNS propagation. The answers actually work.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.