How can I enable HTTP/2 on my R2 bucket?

HTTP/1.1 is currently being used for my R2 buckets, which is lowering my Google Lighthouse score and negatively impacting my site’s user experience. How can I enable HTTP/2 on my R2 buckets?

I’m also hoping for HTTP/2 support soon! :crossed_fingers:

Hi Westy!

HTTP/2 has been enabled for new custom domains for a few weeks now. If you remove the custom domain from your bucket and add it again, it should have http/2 enabled. Let us know if you’re having any issues with that!

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.