Hotlinked pictures with hotlink protection mode turned off. How to fix it?

When I turn on Cloudflare, instead of some pictures I see the picture “Stop. This picture is hotlinked”. But I have the hotlinker protection turned off. What happens and how to get rid of it? When I turn on developer mode, this problem disappears.

Wordpress 6.2

I’ve cleared the website cache, I’ve cleared the browser cache, I’ve cleared the Cloudflare cache - nothing changes.

May I ask if you’re using some kind of a Cloudflare App from the Cloudflare App center? :thinking:

I cannot recall and I don’t remember having this “replacement” image shown while the “Hotlink Protection” feature is enabled at Cloudflare dashboard → Scrape Shield.

However, I am afraid this comes from some other source and it’s not Cloudflare related.

Can you share the URL of the example?

UPDATE: I found that image on Google. Are you using Plesk panel? See the solution for it here:

1 Like

No. This hotlink protection is disabled. I don’t use it.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.