Hotlink protection even when disabled

Hi everyone, somehow when I activate Cloudflare it activates hotlink protection that doesn’t belong to the Scrape Shield → Hotlink protection, since, in my case is not activated.

Is there any other setting that I have to disable in order to bypass that?

Thanks in advance for your help!

What are you seeing that shows Hotlink protection is blocking requests?

Hi, thanks!

When I use a third-party website to create 360 visualizations, for example, it asks me to type the URL of my image and it says that it cannot be displayed due to protection, also in the emails I send with images they don’t display when I enable Cloudflare.

I even check on this page and when I enable Cloudflare they are not visible.

Also to mention that there’s no other hotlink protection at the server, .htaccess, or other plugins for hotlink protection. This only happens when enabling/disabling cloudflare.


Are you seeing these requests in the Firewall Events Activity Log? Or in your server log?

Is not enabled but from the last time I tried I guess they are there,
I have this:

What’s the domain? And who’s the host? They might have Cloudflare settings of their own.

I checked already on the server and there’s no hotlink protection enabled, this only happens when I activate Cloudflare.

Fastcomet is the hosting provider

Fastcomet uses Cloudflare. Did you enable some Cloudflare feature at your host? Ask them if they have a partnership with Cloudflare where they can add settings for your domain.

They said they don’t apply different settings than the ones are applied via Cloudflare admin, so no, this is not the case.

I still think it’s them since it’s not enabled on your account. You’d have to open a ticket here to find out who’s responsible for that setting.

Email them: support AT cloudflare DOT com

Then post the ticket number here.

Done, [Cloudflare Support] 2355327

Let’s see what happens

Ok, I just added that ticket to the escalation queue.

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.