Hotlink issue

Hi everyone I’ve been looking up and down but could not find any answers so I hope you can help!

For a website I run wordpress on it, runs on Plesk VPS with cloudfare

  • Hotlink is disabled in plesk
  • hotlink is disabled in cloudfare
  • cache plugin has been disabled on the wordpress
  • tried page rule by disabling security for the upload folder of wordpress, still the same

after this I still get the messages that there is an hotlink issue and it won’t show any images

I am not sure where to look anymore and almost feeling like pulling the plug on the cloudfare setup… website is fast but not much fun if plastered with hotlink warnings :slight_smile:

thank you !

Did you check at https://dash.cloudflare.com/?to=/:account/:zone/content-protection?

If that is not on, that message wont come from Cloudflare.

That is indeed off, first thing I checked.

As there is no caching plugin and hotlink is off in cloudfare… I can only think something with plesk going on… but there has been no update last couple of weeks and it was working till last week…

any possibility it has to do with cloudfare ?

At worst, you might have something in your Cloudflare cache. Maybe purge it and check if you still have the issue. If not, then you need to be careful about the caching and should probably move the hotlink check to Cloudflare. If you still experience it, it is not Cloudflare related.

my feel is also not to do with CF byt plesk, i’ve dropped them a line:

This topic was automatically closed after 14 days. New replies are no longer allowed.