Hotel booking confirmation page goes to Port 80

Hello,
New user to Cloudfare as want to increase GTmetrix score with CDN for our hotel and it did bump it up but created an issue when a guest books a room then when the booking confirmation page appeared it went to https://example.com:80/book-hotel-now-example/?reservation=complete&inid=830 with Cloudfare activated and a secure connection page appeared. (830 is the confirmation number)

The page without Cloudfare is correct https://example.com/book-hotel-now-example/?reservation=complete&inid=830

I have attachements to show if that helps.
Thanks Pete

Are you saying it didn’t before? If your server is not secure as well, your whole site is still insecure.

You probably best pause Cloudflare, make sure your site loads fine on HTTPS and once it does, it should also work with Cloudflare.

Here is the attachment with Cloudfare on, I had to remove on the portal so we could keep our reservation system active so apologies and hope someone can able to help

Hello Sandro,
I can add back site and pause, would that be the same as me removing as I did?

Your domain does not seem to be using Cloudflare right now. You probably have the URL somewhere not properly configured, though that would be an issue with your site and Cloudflare would not be involved.

Should you experience this on Cloudflare, then it could be also because you have an insecure encryption setting on Cloudflare. Make sure your encryption mode is Full Strict.

1 Like

Sandro, you are a genius! Full Strict fixed it, much appreciated…any other advice to help a newb for settings without glitching our res system

Nothing specific, all settings apply to different use cases. Just make sure to use Full Strict, otherwise you’d have no security and run into such issues.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.